import Foundation
let pattern = #"^[A-Z]+ ([A-Z]* )?([A-Z]+)\n(([A-Z|0-9]*)+ ([A-Z|0-9]* ?)*)?\n([A-Z|0-9)]* )*[A-Z|0-9)]*\n([A-Z|0-9)]* ){1,3}(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY]) [0-9]{5}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
JANE DOE DOE
COMPANY1 ASSOCIATES HUB
1960 W CHELSEA AVE STE 2006R
NEW YORK NY 84054
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)