import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]+ ([A-Z]* )?([A-Z]+)\\n(([A-Z|0-9]*)+ ([A-Z|0-9]* ?)*)?\\n([A-Z|0-9)]* )*[A-Z|0-9)]*\\n([A-Z|0-9)]* ){1,3}(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY]) [0-9]{5}";
final String string = "JANE DOE DOE\n"
+ "COMPANY1 ASSOCIATES HUB\n"
+ "1960 W CHELSEA AVE STE 2006R\n"
+ "NEW YORK NY 84054";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}