const regex = /^[A-Z]+ ([A-Z]* )?([A-Z]+)\n(([A-Z|0-9]*)+ ([A-Z|0-9]* ?)*)?\n([A-Z|0-9)]* )*[A-Z|0-9)]*\n([A-Z|0-9)]* ){1,3}(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY]) [0-9]{5}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]+ ([A-Z]* )?([A-Z]+)\\n(([A-Z|0-9]*)+ ([A-Z|0-9]* ?)*)?\\n([A-Z|0-9)]* )*[A-Z|0-9)]*\\n([A-Z|0-9)]* ){1,3}(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY]) [0-9]{5}', 'gm')
const str = `JANE DOE DOE
COMPANY1 ASSOCIATES HUB
1960 W CHELSEA AVE STE 2006R
NEW YORK NY 84054`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}