$re = '/^<(JeEntity|JeFeld)>/m';
$str = '
#region Satz-Definitionen
<JeEntity>
public class «EntityName»_Satz
{
#region constructor
public «EntityName»_Satz()
{
}
#endregion
<JeFeld>
public «FeldTyp» «FeldNameCSharp» { get; set; }
</JeFeld>
}
</JeEntity>
#endregion
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);