package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<(JeEntity|JeFeld)>`)
var str = `
#region Satz-Definitionen
<JeEntity>
public class «EntityName»_Satz
{
#region constructor
public «EntityName»_Satz()
{
}
#endregion
<JeFeld>
public «FeldTyp» «FeldNameCSharp» { get; set; }
</JeFeld>
}
</JeEntity>
#endregion
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}