$re = '/(?<!\\\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\\\)(?=```)(?P<end>(?:\\\\\\\\)*```)/s';
$str = '```php
$foo = \'Bar\';
define(\'FOO\', \'BAR\');
```
```$foo = \'Bar\';```Foobarbaz
Foobarbaz```$foo = \'Bar\';```
/(?P<start>\\```)(?<=\\```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?=\\```)(?P<end>\\```)/gs
(?<!\\\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?<!\\\\)(?=```php )(?P<end>(?:\\\\\\\\)*```)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);