const regex = /(?<!\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\)(?=```)(?P<end>(?:\\\\)*```)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\\s)?(?P<content>.*?)(?<!\\\\)(?=```)(?P<end>(?:\\\\\\\\)*```)', 'gs')
const str = `\`\`\`php
\$foo = 'Bar';
define('FOO', 'BAR');
\`\`\`
\`\`\`\$foo = 'Bar';\`\`\`Foobarbaz
Foobarbaz\`\`\`\$foo = 'Bar';\`\`\`
/(?P<start>\\\`\`\`)(?<=\\\`\`\`)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?=\\\`\`\`)(?P<end>\\\`\`\`)/gs
(?<!\\\\)(?P<start>\`\`\`)(?<=\`\`\`)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?<!\\\\)(?=\`\`\`php )(?P<end>(?:\\\\\\\\)*\`\`\`)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}