using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\)(?=```)(?P<end>(?:\\\\)*```)";
string input = @"```php
$foo = 'Bar';
define('FOO', 'BAR');
```
```$foo = 'Bar';```Foobarbaz
Foobarbaz```$foo = 'Bar';```
/(?P<start>\```)(?<=\```)(?P<lang>[a-z][a-z0-9]*\s)?(?P<content>.*?)(?=\```)(?P<end>\```)/gs
(?<!\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\s)?(?P<content>.*?)(?<!\\)(?=```php )(?P<end>(?:\\\\)*```)
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}