re = /(?:\s*(?=\w+\.|.*as\s+|distinct\s+|)(\*|\w+)(?=\s*(?=,|from)))/i
str = 'select distinct test, another_column, sum(data) as data_value, customtable.reported from customtable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end