$re = '/(?:\s*(?=\w+\.|.*as\s+|distinct\s+|)(\*|\w+)(?=\s*(?=,|from)))/i';
$str = 'select distinct test, another_column, sum(data) as data_value, customtable.reported from customtable';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);