const regex = /(?:\s*(?=\w+\.|.*as\s+|distinct\s+|)(\*|\w+)(?=\s*(?=,|from)))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*(?=\\w+\\.|.*as\\s+|distinct\\s+|)(\\*|\\w+)(?=\\s*(?=,|from)))', 'ig')
const str = `select distinct test, another_column, sum(data) as data_value, customtable.reported from customtable`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}