$re = '/^\s*((?:[—‘’ \-\w?°]|(?<=\w)[.,:])+?[^ .])[., ]*([-\d]+)$/m';
$str = 'Preface page -1
Preface 2: The Unconscious Juggling of Mental Objects . . . . . ... ... .87
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);