const regex = new RegExp('^\\s*((?:[—‘’ \\-\\w?°]|(?<=\\w)[.,:])+?[^ .])[., ]*([-\\d]+)$', 'gm')
const str = `Preface page -1
Preface 2: The Unconscious Juggling of Mental Objects . . . . . ... ... .87
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}