using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*((?:[—‘’ \-\w?°]|(?<=\w)[.,:])+?[^ .])[., ]*([-\d]+)$";
string input = @"Preface page -1
Preface 2: The Unconscious Juggling of Mental Objects . . . . . ... ... .87
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}