re = /^ecp\.eset\.systems|(?:edf|h(?:[1,3,5]\-arse0[1,2]|5\-arse0[3,4])\-v)\.eset\.com$/mi
str = 'ecp.eset.systems
ecp.eset.systems
edf.eset.com
h1-arse01-v.eset.com
h1-arse02-v.eset.com
h3-arse01-v.eset.com
h3-arse02-v.eset.com
h5-arse01-v.eset.com
h5-arse02-v.eset.com
h5-arse03-v.eset.com
h5-arse04-v.eset.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end