const regex = /^ecp\.eset\.systems|(?:edf|h(?:[1,3,5]\-arse0[1,2]|5\-arse0[3,4])\-v)\.eset\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ecp\\.eset\\.systems|(?:edf|h(?:[1,3,5]\\-arse0[1,2]|5\\-arse0[3,4])\\-v)\\.eset\\.com$', 'gmi')
const str = `ecp.eset.systems
ecp.eset.systems
edf.eset.com
h1-arse01-v.eset.com
h1-arse02-v.eset.com
h3-arse01-v.eset.com
h3-arse02-v.eset.com
h5-arse01-v.eset.com
h5-arse02-v.eset.com
h5-arse03-v.eset.com
h5-arse04-v.eset.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}