import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ecp\\.eset\\.systems|(?:edf|h(?:[1,3,5]\\-arse0[1,2]|5\\-arse0[3,4])\\-v)\\.eset\\.com$";
final String string = "ecp.eset.systems\n"
+ "ecp.eset.systems\n\n"
+ "edf.eset.com\n\n"
+ "h1-arse01-v.eset.com\n"
+ "h1-arse02-v.eset.com\n"
+ "h3-arse01-v.eset.com\n"
+ "h3-arse02-v.eset.com\n"
+ "h5-arse01-v.eset.com\n"
+ "h5-arse02-v.eset.com\n\n"
+ "h5-arse03-v.eset.com\n"
+ "h5-arse04-v.eset.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}