use strict;
my $str = '(osz(ołomieni[ea]?))|(oszałamia(\\b|jąc|jącej))\\b
oszołomieni
oszołomienie
oszołomienia
oszałamia
oszałamiając (ich/go)
oszałamiającej
ogłusza
ogłuszając
ogłuszony
ogłuszenie
ogłuszania
Ogłuszone
ogłuszonym
ogłuszeniu
ogłuszają
4933 abilities <DefaultText>Ogłuszenie</DefaultText>
389 cyclopedia <DefaultText>Ogłuszenie</DefaultText>
5059 gui
!ogłuszający cios
!ogłuszająca fala
!ogłuszający wrzask
-----
wnikliwości
6357 abilities <DefaultText>Wnikliwość</DefaultText>
13695 abilities <DefaultText>Gdy jest z tobą Xopn\'aua, otrzymujesz premię do wnikliwości i metafizyki. Cała twoja drużyna otrzymuje ponadto premię do woli.</DefaultText>
3265 cyclopedia <DefaultText>Wnikliwość</DefaultText>
11841 gui <DefaultText>Wnikliwość</DefaultText>
11846 <DefaultText>Czasami ciężko jest prowadzić rozmowy – rozmówcy bywają mało konkretni, przestraszeni, zajęci czymś innym lub po prostu kłamią. Wnikliwość zwiększa empatię i pomaga zrozumieć emocje oraz motywacje interlokutorów.</DefaultText>
9371 items <DefaultText>Gdy jest z tobą Xopn\'aua, otrzymujesz premię do wnikliwości i metafizyki. Cała twoja drużyna otrzymuje ponadto premię do woli.</DefaultText>
----
intuicji
intuicję
intuicją
2919 abilities <DefaultText>Wytrwałość daje mnichowi zastrzyk intuicji, a wraz z nim premię do hartu, refleksu i woli za każdym razem, gdy niekorzystny efekt wygasa.</DefaultText>
664 gui <DefaultText>W trybie eksperta wyłączone zostają wszystkie funkcje pomocnicze, co czyni go odpowiednim dla graczy chcących polegać wyłącznie na własnych zdolnościach i intuicji. Opcję tę można wybrać wyłącznie podczas rozpoczynania nowej rozgrywki – aktywacja jej w trakcie trwającej gry jest niemożliwa, a dezaktywacja nieodwracalna.</DefaultText>
';
my $regex = qr/test/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}