#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)test"
Local $sString = "(osz(ołomieni[ea]?))|(oszałamia(\b|jąc|jącej))\b" & @CRLF & _
"" & @CRLF & _
"oszołomieni" & @CRLF & _
"oszołomienie" & @CRLF & _
"oszołomienia" & @CRLF & _
"" & @CRLF & _
"oszałamia" & @CRLF & _
"oszałamiając (ich/go)" & @CRLF & _
"oszałamiającej" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ogłusza" & @CRLF & _
"ogłuszając" & @CRLF & _
"ogłuszony" & @CRLF & _
"ogłuszenie" & @CRLF & _
"ogłuszania" & @CRLF & _
"Ogłuszone" & @CRLF & _
"ogłuszonym" & @CRLF & _
"ogłuszeniu" & @CRLF & _
"ogłuszają" & @CRLF & _
"" & @CRLF & _
"4933 abilities <DefaultText>Ogłuszenie</DefaultText>" & @CRLF & _
"389 cyclopedia <DefaultText>Ogłuszenie</DefaultText>" & @CRLF & _
"5059 gui" & @CRLF & _
"!ogłuszający cios" & @CRLF & _
"!ogłuszająca fala" & @CRLF & _
"!ogłuszający wrzask" & @CRLF & _
"" & @CRLF & _
"-----" & @CRLF & _
"" & @CRLF & _
"wnikliwości" & @CRLF & _
"" & @CRLF & _
"6357 abilities <DefaultText>Wnikliwość</DefaultText>" & @CRLF & _
"13695 abilities <DefaultText>Gdy jest z tobą Xopn'aua, otrzymujesz premię do wnikliwości i metafizyki. Cała twoja drużyna otrzymuje ponadto premię do woli.</DefaultText>" & @CRLF & _
"3265 cyclopedia <DefaultText>Wnikliwość</DefaultText>" & @CRLF & _
"11841 gui <DefaultText>Wnikliwość</DefaultText>" & @CRLF & _
"11846 <DefaultText>Czasami ciężko jest prowadzić rozmowy – rozmówcy bywają mało konkretni, przestraszeni, zajęci czymś innym lub po prostu kłamią. Wnikliwość zwiększa empatię i pomaga zrozumieć emocje oraz motywacje interlokutorów.</DefaultText>" & @CRLF & _
"9371 items <DefaultText>Gdy jest z tobą Xopn'aua, otrzymujesz premię do wnikliwości i metafizyki. Cała twoja drużyna otrzymuje ponadto premię do woli.</DefaultText>" & @CRLF & _
"" & @CRLF & _
"----" & @CRLF & _
"" & @CRLF & _
"intuicji" & @CRLF & _
"intuicję" & @CRLF & _
"intuicją" & @CRLF & _
"" & @CRLF & _
"2919 abilities <DefaultText>Wytrwałość daje mnichowi zastrzyk intuicji, a wraz z nim premię do hartu, refleksu i woli za każdym razem, gdy niekorzystny efekt wygasa.</DefaultText>" & @CRLF & _
"" & @CRLF & _
"664 gui <DefaultText>W trybie eksperta wyłączone zostają wszystkie funkcje pomocnicze, co czyni go odpowiednim dla graczy chcących polegać wyłącznie na własnych zdolnościach i intuicji. Opcję tę można wybrać wyłącznie podczas rozpoczynania nowej rozgrywki – aktywacja jej w trakcie trwającej gry jest niemożliwa, a dezaktywacja nieodwracalna.</DefaultText>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")