import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "test";
final String string = "(osz(ołomieni[ea]?))|(oszałamia(\\b|jąc|jącej))\\b\n\n"
+ "oszołomieni\n"
+ "oszołomienie\n"
+ "oszołomienia\n\n"
+ "oszałamia\n"
+ "oszałamiając (ich/go)\n"
+ "oszałamiającej\n\n\n\n"
+ "ogłusza\n"
+ "ogłuszając\n"
+ "ogłuszony\n"
+ "ogłuszenie\n"
+ "ogłuszania\n"
+ "Ogłuszone\n"
+ "ogłuszonym\n"
+ "ogłuszeniu\n"
+ "ogłuszają\n\n"
+ "4933 abilities <DefaultText>Ogłuszenie</DefaultText>\n"
+ "389 cyclopedia <DefaultText>Ogłuszenie</DefaultText>\n"
+ "5059 gui\n"
+ "!ogłuszający cios\n"
+ "!ogłuszająca fala\n"
+ "!ogłuszający wrzask\n\n"
+ "-----\n\n"
+ "wnikliwości\n\n"
+ "6357 abilities <DefaultText>Wnikliwość</DefaultText>\n"
+ "13695 abilities <DefaultText>Gdy jest z tobą Xopn'aua, otrzymujesz premię do wnikliwości i metafizyki. Cała twoja drużyna otrzymuje ponadto premię do woli.</DefaultText>\n"
+ "3265 cyclopedia <DefaultText>Wnikliwość</DefaultText>\n"
+ "11841 gui <DefaultText>Wnikliwość</DefaultText>\n"
+ "11846 <DefaultText>Czasami ciężko jest prowadzić rozmowy – rozmówcy bywają mało konkretni, przestraszeni, zajęci czymś innym lub po prostu kłamią. Wnikliwość zwiększa empatię i pomaga zrozumieć emocje oraz motywacje interlokutorów.</DefaultText>\n"
+ "9371 items <DefaultText>Gdy jest z tobą Xopn'aua, otrzymujesz premię do wnikliwości i metafizyki. Cała twoja drużyna otrzymuje ponadto premię do woli.</DefaultText>\n\n"
+ "----\n\n"
+ "intuicji\n"
+ "intuicję\n"
+ "intuicją\n\n"
+ "2919 abilities <DefaultText>Wytrwałość daje mnichowi zastrzyk intuicji, a wraz z nim premię do hartu, refleksu i woli za każdym razem, gdy niekorzystny efekt wygasa.</DefaultText>\n\n"
+ "664 gui <DefaultText>W trybie eksperta wyłączone zostają wszystkie funkcje pomocnicze, co czyni go odpowiednim dla graczy chcących polegać wyłącznie na własnych zdolnościach i intuicji. Opcję tę można wybrać wyłącznie podczas rozpoczynania nowej rozgrywki – aktywacja jej w trakcie trwającej gry jest niemożliwa, a dezaktywacja nieodwracalna.</DefaultText>\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}