$re = '/\d{4}-\d{2}-\d{2}/m';
$str = '2020
2019/10/16
2020/08/12
31/01/2020
2020-11-03
05/01/2020
04/17/2020
2019/12/31
2021-07-14
2019/12/04
2010/12/16
2021
04/03/2020
4/30/2020
2011/07/18
2017/06/20
2019
2021-10-13
2020
2021-07-14
2021/11/08
2020-11-03
2021
2019/12/31
2019-12-04
null
2020/01/04';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);