import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}-\\d{2}-\\d{2}";
final String string = "2020 \n"
+ "2019/10/16\n"
+ "2020/08/12 \n"
+ "31/01/2020 \n"
+ "2020-11-03 \n"
+ "05/01/2020 \n"
+ "04/17/2020 \n"
+ "2019/12/31 \n"
+ "2021-07-14\n"
+ "2019/12/04 \n"
+ "2010/12/16 \n"
+ "2021 \n"
+ "04/03/2020 \n"
+ "4/30/2020\n"
+ "2011/07/18 \n"
+ "2017/06/20 \n"
+ "2019 \n"
+ "2021-10-13 \n"
+ "2020\n"
+ "2021-07-14 \n"
+ "2021/11/08 \n"
+ "2020-11-03 \n"
+ "2021 \n"
+ "2019/12/31\n"
+ "2019-12-04 \n"
+ "null\n"
+ "2020/01/04";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}