#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{4}-\d{2}-\d{2}"
Local $sString = "2020 " & @CRLF & _
"2019/10/16" & @CRLF & _
"2020/08/12 " & @CRLF & _
"31/01/2020 " & @CRLF & _
"2020-11-03 " & @CRLF & _
"05/01/2020 " & @CRLF & _
"04/17/2020 " & @CRLF & _
"2019/12/31 " & @CRLF & _
"2021-07-14" & @CRLF & _
"2019/12/04 " & @CRLF & _
"2010/12/16 " & @CRLF & _
"2021 " & @CRLF & _
"04/03/2020 " & @CRLF & _
"4/30/2020" & @CRLF & _
"2011/07/18 " & @CRLF & _
"2017/06/20 " & @CRLF & _
"2019 " & @CRLF & _
"2021-10-13 " & @CRLF & _
"2020" & @CRLF & _
"2021-07-14 " & @CRLF & _
"2021/11/08 " & @CRLF & _
"2020-11-03 " & @CRLF & _
"2021 " & @CRLF & _
"2019/12/31" & @CRLF & _
"2019-12-04 " & @CRLF & _
"null" & @CRLF & _
"2020/01/04"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")