import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.*?)\\]\\(.*?\\)";
final String string = "Die **Sacherschließung** ([engl.](https://de.wikipedia.org/wiki/Englische_Sprache) *subject cataloguing*) oder **Inhaltserschließung** bezeichnet innerhalb der [Bibliotheks-](https://de.wikipedia.org/wiki/Bibliothekswissenschaft) und [Dokumentationswissenschaft](https://de.wikipedia.org/wiki/Dokumentationswissenschaft) die Erschließung bibliographischer und archivalischer Ressourcen nach inhaltlichen Kriterien. Das bedeutet, dass eine Ressource intellektuell oder automatisch aufgrund ihres Inhalts beschrieben wird. Im Gegensatz dazu widmet sich die [Formalerschließung](https://de.wikipedia.org/wiki/Formalerschlie%C3%9Fung), die auch als Katalogisierung bezeichnet wird, der Erfassung eines Objekts nach formalen Regeln. Hierbei werden nur Daten herangezogen, die sich unmittelbar ermitteln lassen, z. B. der Titel eines Werkes.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}