using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.*?)\]\(.*?\)";
string substitution = @"$1";
string input = @"Die **Sacherschließung** ([engl.](https://de.wikipedia.org/wiki/Englische_Sprache) *subject cataloguing*) oder **Inhaltserschließung** bezeichnet innerhalb der [Bibliotheks-](https://de.wikipedia.org/wiki/Bibliothekswissenschaft) und [Dokumentationswissenschaft](https://de.wikipedia.org/wiki/Dokumentationswissenschaft) die Erschließung bibliographischer und archivalischer Ressourcen nach inhaltlichen Kriterien. Das bedeutet, dass eine Ressource intellektuell oder automatisch aufgrund ihres Inhalts beschrieben wird. Im Gegensatz dazu widmet sich die [Formalerschließung](https://de.wikipedia.org/wiki/Formalerschlie%C3%9Fung), die auch als Katalogisierung bezeichnet wird, der Erfassung eines Objekts nach formalen Regeln. Hierbei werden nur Daten herangezogen, die sich unmittelbar ermitteln lassen, z. B. der Titel eines Werkes.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}