// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)YOUR REGEX HERE").unwrap();
let string = "should match: moon, moooon, moooooon, muun, muuuun, moon, moooon
should not match: mn, mooon, mon, mun, muu, oooooon, moouun";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}