package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)YOUR REGEX HERE`)
var str = `should match: moon, moooon, moooooon, muun, muuuun, moon, moooon
should not match: mn, mooon, mon, mun, muu, oooooon, moouun`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}