$re = '/YOUR REGEX HERE/m';
$str = 'should match: moon, moooon, moooooon, muun, muuuun, moon, moooon
should not match: mn, mooon, mon, mun, muu, oooooon, moouun';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);