// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)^(
(?:\(?
(?:00|\+)
(?:[1-4]\d\d|[1-9]\d?)
\)?)?
[\-\.\ \\\/]?
)?
(
(?:\(?\d{1,}\)?
[\-\.\ \\\/]?){0,}
)
(?:
[\-\.\ \\\/]?
(?:
#|
ext\.?|
extension|
x
)
[\-\.\ \\\/]?
(\d+)
)?$").unwrap();
let string = "08142 655456-712
0049 8142 655456-712
0049 (8142) 655456
+49 (8142) 655456
+49(8142)655456
+49 8142 655456
(+351) 282 43 50 50
90191919908
555-8909
001 6867684
001 6867684x1
1 (234) 567-8901
1-234-567-8901 x1234
1-234-567-8901 ext1234
1-234 567.89/01 ext.1234
1(234)5678901x1234
(123)8575973
(0055)(123)8575973
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}