# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(
(?:\(?
(?:00|\+)
(?:[1-4]\d\d|[1-9]\d?)
\)?)?
[\-\.\ \\\/]?
)?
(
(?:\(?\d{1,}\)?
[\-\.\ \\\/]?){0,}
)
(?:
[\-\.\ \\\/]?
(?:
#|
ext\.?|
extension|
x
)
[\-\.\ \\\/]?
(\d+)
)?$
"""
test_str = ("08142 655456-712\n"
"0049 8142 655456-712\n"
"0049 (8142) 655456\n"
"+49 (8142) 655456\n"
"+49(8142)655456\n"
"+49 8142 655456\n"
"(+351) 282 43 50 50\n"
"90191919908\n"
"555-8909\n"
"001 6867684\n"
"001 6867684x1\n"
"1 (234) 567-8901\n"
"1-234-567-8901 x1234\n"
"1-234-567-8901 ext1234\n"
"1-234 567.89/01 ext.1234\n"
"1(234)5678901x1234\n"
"(123)8575973\n"
"(0055)(123)8575973\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.