package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(
(?:\(?
(?:00|\+)
(?:[1-4]\d\d|[1-9]\d?)
\)?)?
[\-\.\ \\\/]?
)?
(
(?:\(?\d{1,}\)?
[\-\.\ \\\/]?){0,}
)
(?:
[\-\.\ \\\/]?
(?:
#|
ext\.?|
extension|
x
)
[\-\.\ \\\/]?
(\d+)
)?$`)
var str = `08142 655456-712
0049 8142 655456-712
0049 (8142) 655456
+49 (8142) 655456
+49(8142)655456
+49 8142 655456
(+351) 282 43 50 50
90191919908
555-8909
001 6867684
001 6867684x1
1 (234) 567-8901
1-234-567-8901 x1234
1-234-567-8901 ext1234
1-234 567.89/01 ext.1234
1(234)5678901x1234
(123)8575973
(0055)(123)8575973
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}