$re = '/([\n ]*((<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((\') *.+ *(\'))|(\\\\" *.+ *\\\\")|(\\\\\' *.+ *\\\\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)([\n ]*<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((\') *.+ *(\'))|(\\\\" *.+ *\\\\")|(\\\\\' *.+ *\\\\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)*)[\n ]*$)/y';
$str = '<div attr1="value"></div>
<!-- this is a HTML comment -->';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;