# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\n ]*((<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((') *.+ *('))|(\\" *.+ *\\")|(\\' *.+ *\\')))* *((\\/)|(>([ \n]|.)*<\\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)([\n ]*<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((') *.+ *('))|(\\" *.+ *\\")|(\\' *.+ *\\')))* *((\\/)|(>([ \n]|.)*<\\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)*)[\n ]*$)//gy;t' <<< "<div attr1=\"value\"></div>
<!-- this is a HTML comment -->"