const regex = /([\n ]*((<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((') *.+ *('))|(\\" *.+ *\\")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)([\n ]*<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((") *.+ *("))|((') *.+ *('))|(\\" *.+ *\\")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)*)[\n ]*$)/gy;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\n ]*((<((([a-zA-Z]+)( +(\\w|\\w+-+\\w*)+ *= *(( *(\\w|\\w+-+\\w*)+ *)|((") *.+ *("))|((\') *.+ *(\'))|(\\\\" *.+ *\\\\")|(\\\\\' *.+ *\\\\\')))* *((\\\/)|(>([ \\n]|.)*<\\\/[a-zA-Z]+)))|(!--([ \\n]|.)*--))>)([\\n ]*<((([a-zA-Z]+)( +(\\w|\\w+-+\\w*)+ *= *(( *(\\w|\\w+-+\\w*)+ *)|((") *.+ *("))|((\') *.+ *(\'))|(\\\\" *.+ *\\\\")|(\\\\\' *.+ *\\\\\')))* *((\\\/)|(>([ \\n]|.)*<\\\/[a-zA-Z]+)))|(!--([ \\n]|.)*--))>)*)[\\n ]*$)', 'gy')
const str = `<div attr1="value"></div>
<!-- this is a HTML comment -->`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);