// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\( (.*)(\([A-Za-z0-9,\-]+\))_(.*) - (Google Chrome|Internet Explorer)\)").unwrap();
let string = "( 终端知识库 - Google Chrome)
( 荣耀盒子Pro_电视画面显示不满屏、比例失调或超出屏幕显示区域怎么办? - Google Chrome)
( 多屏互动是什么功能?不同手机如何与盒子进行多屏互动? - Google Chrome)
( 【维修配件价格查询】 - 华为服务与支持 - 华为手机官网 - Google Chrome)
( 华为消费者业务官网-服务与支持 - Google Chrome)
( M2是否支持皮套模式,怎么开启皮套模式 - Google Chrome)
( 荣耀X2(GEM-703L,GEM-703LT)_为什么设置里面有两个IMEI? - Internet Explorer)
( 荣耀6(H60-L01)_电池无法正常充电,如何解决? - Internet Explorer)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}