import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\( (.*)(\\([A-Za-z0-9,\\-]+\\))_(.*) - (Google Chrome|Internet Explorer)\\)";
final String string = "( 终端知识库 - Google Chrome)\n"
+ "( 荣耀盒子Pro_电视画面显示不满屏、比例失调或超出屏幕显示区域怎么办? - Google Chrome)\n"
+ "( 多屏互动是什么功能?不同手机如何与盒子进行多屏互动? - Google Chrome)\n"
+ "( 【维修配件价格查询】 - 华为服务与支持 - 华为手机官网 - Google Chrome)\n"
+ "( 华为消费者业务官网-服务与支持 - Google Chrome)\n"
+ "( M2是否支持皮套模式,怎么开启皮套模式 - Google Chrome)\n"
+ "( 荣耀X2(GEM-703L,GEM-703LT)_为什么设置里面有两个IMEI? - Internet Explorer)\n"
+ "( 荣耀6(H60-L01)_电池无法正常充电,如何解决? - Internet Explorer)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}