# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\( (.*)(\([A-Za-z0-9,\-]+\))_(.*) - (Google Chrome|Internet Explorer)\)"
test_str = ("( 终端知识库 - Google Chrome)\n"
"( 荣耀盒子Pro_电视画面显示不满屏、比例失调或超出屏幕显示区域怎么办? - Google Chrome)\n"
"( 多屏互动是什么功能?不同手机如何与盒子进行多屏互动? - Google Chrome)\n"
"( 【维修配件价格查询】 - 华为服务与支持 - 华为手机官网 - Google Chrome)\n"
"( 华为消费者业务官网-服务与支持 - Google Chrome)\n"
"( M2是否支持皮套模式,怎么开启皮套模式 - Google Chrome)\n"
"( 荣耀X2(GEM-703L,GEM-703LT)_为什么设置里面有两个IMEI? - Internet Explorer)\n"
"( 荣耀6(H60-L01)_电池无法正常充电,如何解决? - Internet Explorer)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.