import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{.+\\})";
final String string = "Erreur PHP\n\n"
+ "{\"okko\":\"OK\",\"valeur\":\"706,999\",\"listeIdentLib\":{\"706\":\"Picard\",\"999\":\"BASE QUALIF\"},\"valOpeR\":\"\",\"statut\":\"ADM\"}\n\n"
+ "TOTO";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}