package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`({.+})`)
var str = `Erreur PHP
{"okko":"OK","valeur":"706,999","listeIdentLib":{"706":"Picard","999":"BASE QUALIF"},"valOpeR":"","statut":"ADM"}
TOTO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}