use strict;
my $str = 'wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/07/list-block-3.svg
wp-content/uploads/may/05/list-block-3.svg
wp-content/uploads/2021/05/list-block-3.svg
wp-content/uploads/2020/02/list-block-3.svg';
my $regex = qr/^wp-content\/uploads\/(?!(2021\/06||2021\/07)\/).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}