import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^wp-content\\/uploads\\/(?!(2021\\/06||2021\\/07)\\/).+$";
final String string = "wp-content/uploads/2021/06/list-block-3.svg\n"
+ "wp-content/uploads/2021/06/list-block-3.svg\n"
+ "wp-content/uploads/2021/06/list-block-3.svg\n"
+ "wp-content/uploads/2021/07/list-block-3.svg\n"
+ "wp-content/uploads/may/05/list-block-3.svg\n"
+ "wp-content/uploads/2021/05/list-block-3.svg\n"
+ "wp-content/uploads/2020/02/list-block-3.svg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}