const regex = /^wp-content\/uploads\/(?!(2021\/06||2021\/07)\/).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^wp-content\\\/uploads\\\/(?!(2021\\\/06||2021\\\/07)\\\/).+$', 'gm')
const str = `wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/07/list-block-3.svg
wp-content/uploads/may/05/list-block-3.svg
wp-content/uploads/2021/05/list-block-3.svg
wp-content/uploads/2020/02/list-block-3.svg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}