re = /^((?!test).)*$/m
str = '/abc/def
/abc/def/#
/abc/def#/
/abc/def/#/
/abc/def/test
/abc/def#/test
/abc/def/#/test
/abc/def/test/dsadasd
/abc/def#/test/dadsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end