$re = '/^((?!test).)*$/m';
$str = '/abc/def
/abc/def/#
/abc/def#/
/abc/def/#/
/abc/def/test
/abc/def#/test
/abc/def/#/test
/abc/def/test/dsadasd
/abc/def#/test/dadsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);