import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!test).)*$";
final String string = "/abc/def\n"
+ "/abc/def/#\n"
+ "/abc/def#/\n"
+ "/abc/def/#/\n"
+ "/abc/def/test\n"
+ "/abc/def#/test\n"
+ "/abc/def/#/test\n"
+ "/abc/def/test/dsadasd\n"
+ "/abc/def#/test/dadsd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}