$re = '/(\d{2}\/\d{2}\/\d{2})\s(\d{2}\:\d{2})\s(\d+)\s(Allow|Reject)\s(.*)(\d+)\s(tcp|udp)\s(.*)\s(.*)\s(\d+)/m';
$str = '09/21/11 10:47 29 Allow Partner-SQL-eComm 46990 tcp Partner-Web-eComm mysql 19999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);