import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}\\/\\d{2}\\/\\d{2})\\s(\\d{2}\\:\\d{2})\\s(\\d+)\\s(Allow|Reject)\\s(.*)(\\d+)\\s(tcp|udp)\\s(.*)\\s(.*)\\s(\\d+)";
final String string = "09/21/11 10:47 29 Allow Partner-SQL-eComm 46990 tcp Partner-Web-eComm mysql 19999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}