const regex = /(\d{2}\/\d{2}\/\d{2})\s(\d{2}\:\d{2})\s(\d+)\s(Allow|Reject)\s(.*)(\d+)\s(tcp|udp)\s(.*)\s(.*)\s(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}\\\/\\d{2}\\\/\\d{2})\\s(\\d{2}\\:\\d{2})\\s(\\d+)\\s(Allow|Reject)\\s(.*)(\\d+)\\s(tcp|udp)\\s(.*)\\s(.*)\\s(\\d+)', 'gm')
const str = `09/21/11 10:47 29 Allow Partner-SQL-eComm 46990 tcp Partner-Web-eComm mysql 19999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}