// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"hsl\(\d{1,3}, +\d{1,2}%, +\d{1,2}%\)").unwrap();
let string = "color: hsl(10, 3%, 19%);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}