const regex = /hsl\(\d{1,3}, +\d{1,2}%, +\d{1,2}%\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hsl\\(\\d{1,3}, +\\d{1,2}%, +\\d{1,2}%\\)', 'g')
const str = `color: hsl(10, 3%, 19%);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}